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ESOV NG Version 2.2 - Release Notes

1. NEW RELEASE DESCRIPTION

1.1 Software and Hardware Requirements

The ESOV NG v2.0 software is available for the following computer platforms:

e Windows XP / Vista / 7 (32-bit)
e Mac OS X Intel 10.5 or above (64-bit)
e Linux (64-bit)

The ESOV NG software requires:
e Version 1.6 or higher of the Java Development kit (JRE). It is already included in
the ESOV NG package for Windows.
e 300+ Mb of hard disk space
e 512+ Mb RAM
o It is advised to have at least 1024 x 786 resolution display

1.2 Installation Executables

An ESOV NG distribution consists of one installer file for each supported computer
platform:

32-bit 64-bit
Mac OS X Intel - EsovNG_macintel64_2_2.dmg
Linux - EsovNG_linux64_2 2.sh
Windows EsovNG_windows_2_ 2.exe -

1.3 Installation Hints
The installation of the ESOV NG will be guided through an Install4j installation wizard.

¢ Windows 32-bit:
Run the executable installer EsovNG_windows_2 2.exe. Follow the instructions
displayed by the installation wizard.

e Mac OS X Intel 64-bit:

Unpack the disk image EsovNG_macintel64_2_2.dmg by double-clicking it in a Finder
window. A new Finder window will be opened, showing the package ‘ESOV NG
Installer’. Double-click the installer package and follow the instructions displayed by
the installation wizard.

e Linux 64-bit:

Simply run the shell script EsovNG_linux64_2_2.sh and follow the instructions
displayed by the installation wizard. Note that you may have to set execution
permission with the command:

sudo chmod a+x EsovNG linux32 2 0.sh

or
sudo chmod a+x EsovNG linux64 2 0.sh
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Note that the ESOV NG installer will overwrite installation folders of previous versions if
the application is installed in the same directory. Please remember to backup your own
data files in case they are stored in the installation directory.

Please check Sections 2 and 3 of the ESOVNG user manual for further information about
the installation and application start-up.

The Section 4.3 of these Release Notes (“"Hints and Tips”) provides useful information
regarding issues than may occur after starting Esov NG.

2. NEW FUNCTIONALITIES

This new release provides the following new functionalities with respect to v2.0:

e Core third-party libraries upgrade

ESOVNG-AN-280: EO CFI SW libraries upgraded to version 4.7

ESOVNG-AN-281: Java updated to version 6

ESOVNG-AN-285: Geotools library upgraded to version 9.5

e Mission support

Add additional spacecrafts and their instrument swaths to the distribution
package: SENTINEL5P, JASON_CS (SENTINEL6), SWARM_A, SWARM_B,
SWARM_C

Instrument swaths for SLSTR added to SENTINEL3
Instrument swaths for ATLID, BBR, CPR and MSI added to EARTHCARE

e GUI and style modifications:

ESOVNG-AN-216: Display 'point'-like zones (small diameter) as a point with
configurable size

ESOVNG-AN-227: The gear icon button in top right position has been
replaced by button with the text ‘Apply” in lower right position
ESOVNG-AN-228: The option "Show Orbit Numbers" has been moved into
the Style window

ESOVNG-AN-268: Satellite and scenario name have been added to the
Zone/Station Database Editors

¢ Handling of ESOV NG input/output files:

ESOVNG-AN-204: The consistency of the orbit information used across SCF
files (e.g. when loading multiple SCF files with information for different
instruments) is checked. In case inter-consistency is not verified the loading
is aborted and the user warned.

ESOVNG-AN-218: When using POF/ROF file to generate the orbits, the
contents of the <Orbit_Settings> structure in file exports (SCF/LLF/UTF)
have been changed to include the filename and validity.

ESOVNG-AN-241: File references in input/output files (scenario files, SCFs)
have been set to point to local path to the file. When importing these files
the application tries to locate the file references according to the file name
and path. In case the files are not found the application notifies the user and
opens a file navigation window.




i, —/“— Ref.: RelNotes-EsovNG2.2
~@CSa [ - @ Issue: 1.0
- =T HIEN S IIE S mEsREa -|"}A Date: 23/04/2015
o B :
-' EARTH OBSERVATION Page: 3/6
SYSTEM SUPPORT

Time segments calculation:

ESOVNG-AN-265: Report zone/station name in Segments lists. Be able to
sort by time, zone/station.

ESOVNG-AN-279: New segment calculation modes added to the Instrument
SCOPE pull down menu: MULTIZONE, MULTISTATION. These modes allow
calculating the visibility time segments using multiple zones or stations with
the difference with respect the ZONE, STATION modes that the overlapping
time segments are merged.

ESOVNG-AN-276: It is possible to perform logical operations (AND, NOT and
OR) on time segments. The operations are performed using previously
generated SCF files. This functionality is available through the application
menu Tools—> SCF logical operations

ESOVNG-AN-244: A mechanism to apply Sun Zenith Angle constraint to the
segments calculation and display has been implemented.

Miscellaneous features

ESOVNG-AN-200: New mechanism to calculate the geodetic distance
between two points.

ESOVNG-AN-225: Longitude and latitude is displayed as a tooltip when
mousing over map location when pressing the ‘CTRL’ key. As long as the
'‘CTRL’ key is pressed, the tooltip is updated when moving around the mouse

ESOVNG-AN-271: Support for TLE files has been added. Currently only
possible for the following missions: CRYOSAT2, ENVISAT, ERS1, ERS2,
GOCE, METOP_A and SMOS. The TLE file needs to be physically stored in the
filesystem.

ESOVNG-AN-274: New zooming mechanism for azimuthal /gnomonic
projection

ESOVNG-AN-275: A new tool window (SSP, sub-satellite point) has been
added to include a time bar. The time bar allows to display the SSP position
at time selected in the slider.

Default layers:

ESOVNG-AN-196: Additional geographical layers (coastlines, country
borders, rivers and lakes, minor islands) added to the default set (under
‘User Shapes’ in the Layer Manager) and background images (under ‘User
Background Images’ in the Layer Manager)

Import and export files:

ESOVNG-AN-160: Small modifications in input/output XML files to harmonize
formats

ESOVNG-AN-176: Export time segments (with instrument swaths) to KML,
from application menu File>Export Segments.. > KML...

ESOVNG-AN-213: Transform shapefiles to ESOV NG zones, from Tools -
Shapefile to Zones

ESOVNG-AN-226: Import file with list of Longitude/Latitudes and display as
points (with labels and size) from File=>Import...>Point of interest...
ESOVNG-AN-283: Import file with list of UTC times and display location of
Sub-Satellite Point for those times, from File>Import...>Sub-Satellite point...
Tools>Import...>Shapefile...

ESOVNG-AN-328: The UTC time has been added to the SCF file export
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3. CLOSED SPRS

The following SPRs have been closed:

ESOVNG-AN-191: Grid labels incorrectly located when step < 1 degree resolution
ESOVNG-AN-193: Error message if East and West longitude are set to the same
value

ESOVNG-AN-210: At the beginning and at the end of a multiple point swath the
area should not be filled

ESOVNG-AN-211: Wrong segments for SIX POINTS swath (OPEN and CLOSED).
Related to EOCFI-AN-440

ESOVNG-AN-215: Irregularities when plotting circular zones with small diameter
ESOVNG-AN-219: The application displays the complete segment if SCF contains a
single segment (across orbits) and #Orbits=1

ESOVNG-AN-220: The SDF to STF usage is not accurate when using POF/ROF
ESOVNG-AN-221: When using a POF, if SCF is loaded and 'No' is selected in the
dialog window (use current orbit settings) the displayed segments are wrong
ESOVNG-AN-245: a) A zone across the 180 meridian is not displayed correctly. b)
The exported image is not complete (after centering at long=117, lat=0.0)
ESOVNG-AN-253: Validation of the contents of the Orbit tool window should be
done when clicking on 'Apply', and not while typing

ESOVNG-AN-266: Closed swaths are not displayed correctly (missing bit at the
beginning and at the end of the swath)

ESOVNG-AN-267: Gnomonic projection - Sometimes it is not possible to perform
image rendering image

ESOVNG-AN-269: Diameter in circular zones is ignored (considered as point zone)
ESOVNG-AN-284: Station perimeter not displayed correctly for different values of
AOS/LOS/mask selection flag

4. ADDITIONAL COMMENTS AND KNOWN PROBLEMS

4.1

Mission Support

Orbit Scenario Files (OSF) for the supported missions can be found in the EOP System
Support web server, under the link:

http:

€0op-

cfi.esa.int/index.php?option=com_content&view=article&id=99&Itemid=507&jsmallfib=1&

dir=JSROOT/DOWNLOAD

4.2

Known Problems

The current ESOV NG release has de following open anomalies:

ESOVNG-AN-241: Save scenario file with POF/ROF. Load scenario file. The number
of orbits is not the one from scenario file, but the complete range.
ESOVNG-AN-292: Groundstations file: If Satellite List is present and satellite name
is not exactly equal to any of Esov NG satellites, the application does nothing
without giving a message

ESOVNG-AN-293: Zone Database file: When loading Zone BD file including a
Point/Circular Zone with diameter zero, the application returns an error if zone
added to scenario
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e ESOVNG-AN-294: If syntax error in IDF, the error message "Spacecraft IDF file(s)
cannot be read. Improper IDF file setup. Cannot continue - will exit" does not
inform the user in which IDF file there is a problem

e ESOVNG-AN-302: When loading SCF, the swath colours in Style / Layer Manager
are not consistent with colours as set in SCF

e ESOVNG-AN-306: Datum line (180 deg. longitude) looks thinner than other
meridians (in world view)

e ESOVNG-AN-314: Error computing swath intersection with a zone for swaths that
cross the pole

e ESOVNG-AN-332: In Windows, the application returns an error and exits after
making calculations and changing map projection when ground station is added to
the scenario.

4.3 Hints and Tips

If your system has a previous installation of ESOV NG, you may see the following
error window when launching the application:

Error RS

® The file defaultstations.dbf could not be read - wrong format or not a station database!
Impossible to proceed - exiting immediately.

This problem is due to an incompatibility with the previous version of the
defaultstations.dbf file. The way to solve the problem is to delete the existing file
defaultstations.dbf. This file can be found in the user application folder. See Section
2.5.2 in the User Manual for further instructions about how to locate the user
application directory (location is platform dependent)

If your system has a previous installation of ESOV NG you may not see the latest
default layout. In order to see it, just go to the user application directory (see
Section 2.5.2 in the User Manual), rename (or remove) the existing file
myLayout.layout and launch again ESOV NG.

If for any reason the tool windows do not appear in the main window frame, you can
restore the default layout by selecting "Window > Reset Layout”

o If the style of the segments is changed, a window pops up to warn the user that the
style of the individual segments is lost after recomputation. To block the warning
window please select the option 'Do not show this message again’

e In order to import a LLF or UTF file export type .csv using a spreadsheet application,
load it as external data and select ‘semicolon’ as delimiter. To correctly import the
decimal seconds in the UTC time, you just need to customize the cell format to
hh:mm:ss.000

e It is possible to display ESRI shapefiles. The “shapefile” must consist of the following
physical files:
*.dbf - attributes in dBase format
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*.prj - the projection
*.shp - the geometry data
*.shx - the geometry indices

The user shapefiles have to be stored in the folder “user_shape_files”, under the
application directory (see Section 2.5.2 in ESOV NG User Manual) prior to launch
ESOV NG. The contents of this folder are scanned at start-up and the list of
detected shapes is shown under the ‘User Shapes’ entry in the Layer Manager.
Then, a new entry ‘User shapes’ appears in the Layer Manager.

e Please check the ESOV NG user manual for further information.

5. REPORTING PROBLEMS

For any problems or questions please send an e-mail to the ESOV NG helpdesk:

esov@eopp.esa.int




