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1. INTRODUCTION 

The Space to Ground Data Viewer (S2G) [AD.1, AD.2, AD.3, AD.4, AD.5, AD.6, AD.7] is an 

extensible utility tool to support ground systems engineers during the test campaigns to inspect the 

contents of the communication channels between the signal-in-space and the ground systems apparatus. 

This manual provides detailed information on how to use S2G to inspect files storing CADUs, TFs and 

ISPs. Apart from describing the several components of the S2G application itself, this manual provides 

also information about nominal operations and procedures to extend S2G to support other missions (i.e. 

data formats). 

The following sections of this document are organized as follows: 

➢ Section 2 lists applicable and reference documents 

➢ Section 3 provides instructions to install and launch the application. 

➢ Section 4 presents the several components of S2G. 

➢ Section 5 provided a detailed description of the S2G operations and related customization 

procedures. 

➢ Section 6 shows some troubleshooting procedures. 

1.1. Acronyms and Abbreviations 

The acronyms and abbreviations used in this document are the following ones: 

Acronym Description 

CADU Channel Access Data Unit 

DME DEIMOS Engenharia 

GUI Graphical User Interface 

ISP Instrument Source Packet 

S2G Space to Ground 

SoW Statement of Work 

TF Transfer Frame 
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2. RELATED DOCUMENTS 

2.1. Applicable Documents 

The following table specifies the applicable documents that shall be complied with during project 

development. 

Table 1: Applicable documents 

Reference Code Title Issue 

[AD.1] S2G-DME-TEC-TNO005 S2G Data Viewer Technical Note: Technical 

Specification 

1.A 

[AD.2] S2G-DME-RCR-ECP032 S2G Data Viewer: Proposal for CCN1 Activities 1.B 

[AD.3] S2G-DME-RCR-ECP056 S2G Data Viewer: Proposal for CCN2 Activities 1.C 

[AD.4] S2G-DME-RCR-ECP075 S2G Data Viewer: Proposal for CCN3 Activities 1.B 

[AD.5] S2G-DME-RCR-ECP094 S2G Data Viewer: Proposal for CCN5 Activities 1.B 

[AD.6] S2G-DME-RCR-ECP111 S2G Data Viewer: Proposal for CCN7 Activities 1.A 

[AD.7] S2G-DME-RCR-ECP117 S2G Data Viewer: Proposal for CCN8 Activities 1.A 

2.2. Reference Documents 

The following table specifies the reference documents that shall be taken into account during project 

development. 

Table 2: Reference documents 

Reference Code Title Issue 

[RD.1] S2G-DME-TEC-TNO014 Technical Note: DFDL for S2G 1.F 

[RD.2] ECSS E-70-41 Ground systems and operations - Telemetry & 

telecommand packet utilisation 

 

[RD.3] S2G-DME-TEC-SUM092 Mission Specification Schemas Developer’s Manual 1.C 

[RD.4] CCSDS 727.0-B-4 CCSDS File Delivery Protocol (CFDP) 

https://public.ccsds.org/Pubs/727x0b5.pdf 
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3. GETTING STARTED 

3.1. Introduction 

Satellite house-keeping telemetry or science instruments data is transmitted to the ground sensor stations 

in a packets hierarchy (see Figure 1) that is defined according to a standard format, e.g. [RD.2]. Based 

on that standard format, each mission customizes the packets hierarchy to according to its specific needs 

and instruments. 

Sync
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Frame

Header
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Packet
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Packet
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Figure 1: Hierarchy of Data received by the Ground Sensor Stations 

 

The Space to Ground Data Viewer (S2G) displays the contents of the communication channels between 

the signal-in-space and the ground systems apparatus. It interprets files containing concatenated 

CADUs, TFs or ISPs, and lists of available data units and displays the fields and associated values 

inside each data unit. The tool also provides a hexadecimal viewer to allow low-level data inspection. 

This document uses the designation of data unit when the type of the data item (CADUs, TFs or ISPs) is 

not relevant for the context. 

3.1.1. CFDP Extension 

The CCSDS File Delivery Protocol (CFDP) operates at the Application Layer of the ISO protocol stack 

and provides a file based service that transfers data to Ground. CFDP generates a sequence of Protocol 

Data Units (PDUs) containing File Metadata, a sequence of data PDUs (containing file segments) 

followed by and End-of-File PDU.  

See [RD.4] for further information. 
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Figure 2: Hierarchy of Data received by the Ground Sensor Stations (CFDP Extension) 

3.2. Installation 

To install S2G proceed as follows: 

 Linux & Windows 

1. Unzip the distribution archive (list of available archives Table 3) into the installation directory. 

macOS 

1. Open dmg and drag the s2g folder from the dmg window into Application folder. 

To start the application, follow the instructions in Section 3.3 (How to Start S2G). 

S2G is available for several platforms. Please use the version supporting your platform (according to 

Table 3). The installation should consider the minimum requirements presented in Table 4. The 

platforms presented have been used to support testing activities. 

Table 3: Installation Archives 

Archive Supported Platform 

s2g-<version>-linux.gtk.x86_64.zip Linux (64 bit) 

s2g-<version>-macos.cocoa.x86_64.dmg macOS (64 bit) 

s2g-<version>-macos.cocoa.aarch64.dmg macOS (arm64) 

s2g-<version>-win32.win32.x86_64.zip Windows (64 bit) 
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Table 4: Minimum System Requirements 

Platform Requirements 

Linux (64 bit) RAM: 

Disk Space: 

Dependencies: 

2 GB 

258 MB 

Java 11 

macOS (64 bit) RAM: 

Disk Space: 

Dependencies: 

2 GB 

248 MB 

Java 11 

Windows (64 bit) RAM: 

Disk Space: 

Dependencies: 

1 GB 

243 MB 

Java 11 

3.3. How to Start S2G 

S2G supports multiple platforms, namely Windows, Linux and macOS. Following are instructions to 

start using the tool in each of these platforms, considering that the S2G has been previously installed 

(see section 5.1 for details on how to perform the installation). After launch, the S2G application 

window shall be presented as displayed in Figure 3. 
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Figure 3: S2G Data Viewer Application Window1 

 

3.3.1. Windows  

To start S2G on Windows, follow these steps  

1.  In the Windows Explorer, navigate into the installation directory 

2.  Double click the ”s2g.exe” application to start S2G 

 

3.3.2. Linux 

To start S2G on Linux, follow these steps  

1.  In the System Explorer (e.g. Nautilus), navigate into the installation directory 

2.  Double click the ”s2g” application to start S2G 

 

3.3.3. macOS 

To start S2G on macOS, follow these steps  

1.  In the Finder, navigate to the installation directory 

2.  Double click the ”s2g” application to start S2G 

3.4. Inspection of Data Unit Files 

The S2G Main Window provides all the functionalities supporting the inspection of files storing 

CADUs, TFs and ISPs. Follow through to the section 4 for a detailed presentation of the interface 

components. For information about configuring and operating S2G refer to section 5. 

 

 

1 The Eclipse RCP framework used to develop S2G shall render graphical widgets differently in order to integrate the 

current operating system look-and-feel. The figures shown in this manual have been rendered using the Linux platform. 
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4. S2G DATA VIEWER 

S2G is composed of a window GUI that contains several views, each presenting different details of the 

data stored in the binary data files – details of this GUI are presented in section 4.1. 

The mission configuration files are described in section 4.2. The configuration file is an XML file that 

provides information required by the GUI to display the data. The definition of the mission binary data, 

namely the data fields for CADU, TF and ISPs, is defined using DFDL [RD.1]. 

4.1. S2G GUI 

4.1.1. Application Window 

The S2G graphical user interface is composed of a main application window that contains several views 

used to display specific information about data files. The application main window also provides the 

application menu and a tool bar with shortcuts to most common actions. 

Figure 4 highlights the following components of the main application window: 

1. Menu 

2. Tool bar 

3. Product Files View 

4. Data Unit List View 

5. Data Unit Details View 

6. Hexadecimal View 

7. Status Bar 

8. Memory Indicator 
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Figure 4: Components of the Application Window 

 

S2G has been developed using the Eclipse RCP framework which renders graphical widgets differently 

depending on the underlying operating system. As such, the operating system configurations, namely 

the windows style and font selection, are expected to change the application’s look-and-feel. 

  

4.1.2. Menu and Toolbar 

The menu and toolbar shown in Figure 5 enable the user to operate the tool. They provide actionable 

menu items and buttons that allow operations such as open and close product files, or configure the 

active mission. 

 

Figure 5: Menu and Toolbar 
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4.1.2.1. Menu Contents 

The main menu provides six sub-menus each containing specific operations – as presented in Figure 6. 

The menu is organized as follows: 

➢ Main Menu, contains sub-menus: 

o File, with operations 

▪ Open File, opens a selection dialog enabling the user to choose the file to open – 

see section 5.6 for details on how to open a file. 

▪ Close File, closes the currently selected file – see section 0 for details on how to 

close a file. 

▪ Export, outputs to file the data units currently limited in the Data Unit List. 

▪ Exit, closes the application. 

o Edit 

▪ Preferences…, opens the preferences dialog to edit the tool configuration 

▪ Mission Configuration…, opens the configuration dialog to manage mission 

configuration files. 

o Tools 

▪ Transform, opens the transformation dialog to transform the currently selected file 

▪ Transform File…, opens the transformation dialog to transform the file to be 

selected by the user 

▪ Concatenate, concatenates the currently selected files into a single data file 

▪ Show Report, starts the analysis of the selected file to produce a data quality report 

▪ Batch Report, produces a data quality report for a selected set of files or folders 

containing a given data type files. 

▪ Show Plot, starts the analysis of the selected file to produce 2D data plot 

▪ Mask Editor, launches the support tool to help define the synchronization masks. 

o Scripts 

▪ Execute Script, shows the list of scripts available for execution on S2G. The 

selected script shall be executed over the selected product file. 

▪ Locate Script…, opens the platform default file explorer in S2G scripts folder. 

o Window 

▪ Reset Views, allows the user to reset the default location of the several views. 

▪ Toggle Find Bar, shows/hides the find bars associated with field details and 

hexadecimal views. 

o Help 

▪ Open Help, displays the S2G help page 

▪ Documentation, links to support documentation for S2G/DFDL. 
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▪ About S2G, displays the S2G development credits dialog. 

▪ Check for updates, connects to S2G server to check for an updated version of the 

software or the mission configuration files. 

 

 

 

 

 

 

 

 

 

Figure 6: Menu Details 

4.1.2.2. Toolbar Contents 

The toolbar provides easy access to usual operations. As observed in Figure 7, the following operations 

are available (in sequence): 

➢ Open File 

➢ Close File 

➢ Edit Preferences 

➢ Toggle Find Bars 

➢ Show Report 

➢ Show Plot 

➢ Transform 

 

Figure 7: Toolbar Details 

4.1.3. Product Files view 

The Product Files view (presented in Figure 8) displays the list of open files in a tabular form. The view 

provides information about file size and, when hovering the mouse pointer over the file name, shows a 

tooltip with the complete file path. Additionally the view contains a visual clue on whether the file has 
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already been checked for errors by producing the Quality Report (refer to section 5.9) – ‘V’ for checked, 

‘?’ for not yet checked. 

Apart from displaying the list of open product files, this view is used to select the files to inspect. Using 

the mouse (or the cursor keys, if the view is in focus), the user can select a particular file. Selecting a 

file will result in the automatic update of all other views. 

 

 

Figure 8: Product View 

 

4.1.4. Data Units List view 

The list of data units stored in the currently selected product file is provided by the view shown in 

Figure 9. As can be observed in the figure, the overall structure of the view is the same for all types of 

data units, consisting of a tabular display of the content items. 

The display provides default columns for all types of contents: data unit order inside the file; type of 

data, offset from the beginning of the file and lower level error indicator (active when the “Show 

internal code block structure” toggle button is enabled – refer to section 4.1.5). The mission 

configuration allows adding additional columns to the displayed data (refer to section 5.13 for 

customization details). For the default missions, the values of the following fields are added to the list: 

➢ For TF, display Virtual Channel Id and Virtual Channel Frame Count 

➢ For ISP, display Source Sequence Counter, APID and Time Code Field 

For ISP, assume the value for the column ‘Time Code Field’ as UTC Time Code. 

In order to help the user to identify related items, S2G provides a colour coding scheme. The colour 

coding scheme uses the value of one of the additional columns, as defined by the user in the 

configuration. Packets with the same value are painted in the same colour. The examples in Figure 9 

show the colour coding applied to TFs and ISPs.  

Further details on how to define additional columns and specify colour coding are provided in section 

5.13. 
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Figure 9: Data Units List View 

 

The Data Units List enables the user to select a data unit by: clicking over the data unit with the mouse; 

through cursor keys (when the view is in focus); or pressing next/previous buttons – see Figure 11. 

Upon selection of a unit, the data unit details view and hexadecimal view are automatically 

synchronized with the newly selected item: the data unit details view displays the internal structure of 

the item; and the hexadecimal view auto-scrolls the show the beginning of the item. 

After selecting a specific field in the Content Details view, the user can re-focus the selection on the 

content item by double-clicking on the item – this action clears any existing field selection. 

This view enables four functionality buttons:  

➢ On demand quality check (signalled by a check mark): apply the Reed-Solomon check (at CADU 

level) or the CRC check (TF level) for the selected data unit.  Upon executing the quality check 

the status of the RS and CRC fields in the Data Unit details view changes depending on the result 

of the check (refer to section 4.1.5). The check applies only for the data level of the open file, i.e., 

if a CADU file is open displaying also the CRC fields of the underlying TF, then the quality 

check shall only apply to the RS at CADU level; 

➢ Find data unit (signalled by the bull’s-eye mark): allows jumping to a given data unit given its 

order number inside the file. When this function is activated the indication “Jump to data unit:” is 

displayed in a dialog box allowing the user to enter the intended unit number. When a number 

(between the possible range) is given, it shows the selected item. If the number provided is not in 

the possible range, it shows a warning saying “Data unit out of range”. A warning is also showed 

when the index is not valid. The action can be cancelled with the “Esc” key. 
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Figure 10: Jump to Data Unit 

 

➢ Limit Range (signalled by the narrowing icon):  allows limiting the display of data to a given time 

window. The user is requested an interval of data unit numbers and the Data Unit List shall 

display only the data units within that interval. This limitation can then be switched on/off. 

➢ Export Range (signalled by the file icon): outputs to file the data units currently limited in the 

Data Unit List (as per the Limit Range capability). 

The Filter area allows writing on a text box for searching any data on the file depending on the available 

field selected from the combo box that follows the mission configuration or by selecting Custom for a 

customized search criteria. 

This view provides an information bar in the lower part of the window, were the number of available 

units is displayed. The information bar also displays the order index of the currently selected unit. The 

latter is a helpful indication to the user as the unit selection is not affected when the unit goes out of 

view. 
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Figure 11: Details of the Data Unit List View 

 

When S2G detects problems or inconsistencies in a data unit, it is highlighted in the view as follows: 

➢ data units with problems in data stream synchronization, are highlighted by the entire background 

of the row in red - Figure 12 (this colour can be consulted in the Preferences, refer to section 

4.1.7). 

➢ data units with schema syntactic errors (such as expressions malformed or element paths not 

found), are highlighted by the entire background of the row in orange - Figure 13 (this colour 

can be consulted in the Preferences, refer to section 4.1.7). 

➢ data units with minor inconsistencies (such as having fields with unexpected values), are 

highlighted using a red font - Figure 14 (this colour can be configured in the Preferences, refer 

to section 4.1.7). 
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Figure 12: Data stream 

synchronization error 

highlighting (red background) in 

the Data Unit List View. 

 

Figure 13: Schema syntactic error 

highlighting (orange background) 

in the Data Unit List View. 

 

Figure 14: Minor inconsistencies 

error highlighting (red font) in 

the Data Unit List View. 

S2G identifies idle data units highlighting them in the list with an italic grey font. 

4.1.4.1. CFDP Extension 

Two additional data unit types (CFDP Space Packet and CFDP PDU) are available. 

For CFDP PDU data unit types an additional functionality button is available in the Data Unit List view: 

➢ Transaction ID List (signaled by  icon): allows to jump to Transaction ID List tab. The tab 

shows the list of transaction IDs available in the PDU stream, the filename and file status 

(COMPLETE=file complete, INCOMPLETE=data gaps present in file, MALFORMED= 

incoherent file size). The status may also have an additional message in it. 

 

 

Figure 15: Transition Id List 
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This tab enables 2 functionality buttons: 

➢ Completion Map: The completion map (signaled by  icon) displays whether the File Data PDUs 

are complete or present gaps (at byte level). The information to check the presence of gaps is 

retrieved from relevant size fields in Metadata/EOF PDUs and Segment offset field in File data 

PDUs. 

 

Figure 16: Completion map 

➢ Save File Data (signaled by a save-to-disk icon): Outputs to a file the contents of the File Data 

PDUs units (thus excluding File Directive PDUs, e.g. Metadata and EOF PDUs). 

4.1.5. Data Unit Details view 

Each data unit inside a file is defined in the mission data schema through a hierarchical structure, in 

which leafs are the actual fields of the item. These fields are then grouped into sequences of fields, or 

with other groups. The hierarchical structure of each item is displayed in the Contents Details view – 

Figure 17 shows the content of an ISP. 

The hierarchy of nodes can be expanded to display details of field organization and values. Each 

element of the hierarchy is represented in a tabular way, with the following attributes: 

➢ The name 

➢ The type of the representation (this type is defined by the user, and defines how the value is 

represented in the value column. 

➢ The value, according to the type of representation 

➢ The size of the element (the actual size of the element if a field; otherwise the sum of the size of 

child elements). 
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The values are represented according to default representation types specified in [RD.1]. To enhance 

data inspection, the tool displays a tooltip (as shown in Figure 17) that shows alternative representations 

of the field values in Binary, Hexadecimal and Unsigned Integer. 

When representation type is of ‘Time’ type, time is displayed as UTC time string (as shown in Figure 

17). 

In the Binary representation the octets assigned to the field are fully represented, replacing the irrelevant 

bits with a ‘.’. For both Hexadecimal and Unsigned Integer representations the underlying octets is 

cleaned of the irrelevant bits and then right shifted before displayed in the tooltip. 

Each element representing a field or a group of fields can be selected using the mouse or the cursor keys 

(when view is in focus). When an element is selected, the bytes in which it is stored are highlighted in 

the Hexadecimal view.  

 

Figure 17: Contents Details View (ISP Example) 

When S2G detects inconsistencies in a data unit field, the field is highlighted by being show in red (as 

shown in Figure 17). 

Error detection fields like Reed-Solomon field in CADUs or CRC field in TF are highlighted by being 

shown in blue. This colour means the quality check hasn’t been performed for that particular data unit. 

Upon performing the quality check either by generating a report or by using the on-demand quality 

check functionality (see section 4.1.4) the colour shall change to red in case of failed check or green in it 

passed. 

The underlying tree structure that supports the contents details can be expanded or collapsed using the 

tree button on the top right corner. The lock button enables/disables showing internal block code 

structure (e.g. in a TF showing the contained ISPs).  

The view enables four functionality buttons:  

➢ Show internal code block structure (signalled by a lock icon): show/hide the underlying structure 

of data levels contained in the current file data level (e.g. ISPs inside a TF); 

➢ Expand/Collapse the entire tree structure (signalled by the hierarchy icon); 
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➢ Show Packet Details Colouring (signalled by the colour palette icon):  Colours the tree structure 

highlighting the predefined sections of the shown packet; 

➢ Visually propagate lower level errors (signalled by the beacon icon): highlight in error indication 

dolour the whole path from the lower level field containing an error up to the tree structure top. 

4.1.6. Hexadecimal view 

The Hexadecimal view, shown in Figure 18, displays the bytes of the files in two areas, indexed by the 

offset from the beginning of the file: 

➢ On the left, a table with the bytes/octets (displayed in hexadecimal) 

➢ On the right, a table with the text representation of the file contents. 

In order to assist inspection of the file contents it is important to map the structure of the file contents 

(i.e. CADUs, TFs, and ISPs) to the actual raw data. The Hexadecimal view provides this mapping 

mechanism. This view provides the following highlights. 

➢ The bytes related to the selected item in the Contents List View are highlighted – the fields 

directly below the parent node of the hierarchy are highlighted with different colours. Figure 18 

shows these fields (usually representative of standard packet sections) in green, yellow and 

blue. 

➢ The bytes related to the selected element in the Content Details View are highlighted. This 

selection is represented in pink on Figure 18. 

 

 

Figure 18: Hexadecimal View with Standard Sections 

 

Additionally to the automatic highlight provided by S2G, the user can also select a group of bytes using 

mouse gestures (i.e. click-and-drag selection). When performing mouse selection, the selected area is 

highlight in grey. 

Besides selection, the tool allows a jump to functionality in which the user can jump to the item related 

to a specific byte. This functionality is activated by double-clicking on a previously mouse selected area. 

This action results in automatic selection of the item in the Content List View and auto-scroll of the 
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Hexadecimal view to the beginning of the selected item. Any field selection in Content Details view is 

cleared by this action. 

The hexadecimal view provides an information bar with information about the current selection. Notice 

that the provided information (Offset, Value and Selection) is related to: in first place, the mouse 

selection if any; otherwise the information represents the selection related to the field in Content Details 

view.  

The values of the offsets on the left of the octet table and, on the information bar, the offset and value of 

current selection can be displayed in either decimal or hexadecimal. To toggle between these two 

modes, the user has just to double click over the Representation label – “Hex” on the bottom left of 

Figure 18. The value of the label is either “Hex” or “Dec” according to selected representation 

(Hexadecimal or Decimal, respectively). 

The Hexadecimal view also provides functionality to Find Position (signalled by the bull’s-eye mark in 

Figure 20): allowing jumping to a given data unit given its offset. When this function is activated the 

indication “Jump to data unit:” is displayed in a dialog box allowing the user to enter the intended offset 

either in Hexadecimal or Decimal format, depending on the selected display mode. When a number 

(between the possible range) is given, it shows the selected item. If the number provided is not in the 

possible range, it shows a warning saying “Data unit out of range”. A warning is also showed when the 

index is not valid. The action can be cancelled with the “Esc” key. 

 

Figure 19: Jump to Position 

 

The user can modify the number of columns visible, by clicking on the plus/minus buttons on the top 

right of the view. 

For the specific case of Transfer Frames, the Hexadecimal View highlights the first byte of the 

instrument source packet that begins in the frame data. This byte is highlighted by placing a red box at 

the octet corresponding location (see near mouse pointer in Figure 20) 
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Figure 20: Hexadecimal View with First Packet in TF 

 

4.1.7. Preferences 

The preferences or configuration parameters of the tool can be updated by activating the menu item 

“Edit” → “Preferences” to display the preferences page. The dialog to select the active mission is shown 

in Figure 21. More details on how to select active mission on section 5.4. 

 

 

Figure 21: Preferences (Mission Configuration) 

 

S2G provides a Mission Explorer interface as part of the preferences page – see Figure 22. This allows 

the user to check some details of the configuration without having to open the xml files with the mission 

data configuration.  
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Figure 22: Preferences (Mission Explorer) 

 

S2G provides general Application Settings as part of the preferences page – see Figure 23. This allows 

the user change basic behaviour of the tools, namely: data unit offset synchronization, enable/disable the 

update check at startup, disable/enable the generation of debug information; configure the number of 

events to be stored in the quality report, manage the parameters the configure the offset file cache (set 

maximum cached files and reset the cache), enable/reset ambiguous data definition selection and also 

select the colour used to highlight severe errors in the Data Unit List. 

  

 

Figure 23: Preferences (Application Settings) 

4.1.7.1. Mission Configuration 

The mission specification available in the tool can be configured by activating the menu item “Edit” → 

“Mission Configuration” to display the configuration page. This functionality enables the user to extend 
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S2G to support custom missions. How to configure new missions is described on section 5.5 

(customization of mission data is covered in section 5.13). 

 

Figure 24: Mission Configuration 

4.1.8. Help and About 

The help can be displayed through the menu item “Help” -> “Open Help”. How the help is displayed 

depends on the Platform/OS. In Windows a window with the help is displayed, while in macOS and 

Linux OS the help information is accessed through the pre-defined web browser. Since help is provided 

through a built-in webpage client, firewall access must be granted to the tool for correct usage. Figure 

25 provides an example of the Help interface in Linux. 

 

Figure 25: Help Dialog (in Linux platform) 

 

The about dialog is accessible through the menu item “Help” -> “About”. Figure 26 provides the about 

dialog. 
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Figure 26: About Dialog 

4.2. Mission Configuration 

S2G takes a set of mission configurations as inputs, composed of several separate files. The tool 

provides a set of default mission configurations, that the user can expand by following the procedure 

described in section 5.5. 

The default mission configuration files are available inside the workspace location, which is a folder 

containing auxiliary data, created during the first execution of the application. The location of the 

workspace depends on the installation platform, as follows: 

➢ For Windows and Linux, the workspace location is created inside the installation directory 

➢ For macOS, the workspace location is created inside the app directory related to S2G. 

Inside the workspace, each mission configuration is stored in a separate directory available through 

$WORKSPACE/resources/data. 

The files composing the Mission Configuration (Figure 27) provide a wide range of configuration 

parameters used by the application, and can be divided in two groups: 

➢ the Mission Definition file is an xml file that contains the mission definition parameters used by 

the GUI (such as mission name, the list of searchable or hidden fields); this file also contains the 

reference to the schemas defining the structure of the binary data. 

➢ the Mission Data Definition schema files are a set of schemas that define the binary contents of 

the several levels of packages (CADU, TF and ISP) based on the DFDL [RD.1]. 

mission_CADU.xsd

mission_VCDU.xsd

mission_ISP.xsd

mission_CADUtypes.xsd

mission_TFtypes.xsd

mission_ISPtypes.xsd

includes

includes

includes

Includes

mission.xml

refers

re
fe

rs

refers

mission_ISPData.xsd

includes

CCSDSTIme.xsd

includes
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Figure 27: Mission Configuration files structure 

 

The following sections present details of the two types of configuration files. 

 

4.2.1. Mission Definition File 

The Mission Definition file is an xml file (see Figure 28 for an example) that specifies list of schemas 

used to interpret the binary data. The file stores the mission name, and it also provides for each type of 

file, additional information used by the GUI. 

Each schema element in the file defines: 

➢ The file, which is the actual file containing the schema definition 

➢ The search element, that stores the list of fields that should appear as option in the find bar 

➢ The invisible element that stores the list of fields that should be hidden from the hierarchical 

representation in the Content Details view. 

➢ The packet_list_columns element that stores the list of fields to be displayed as extra columns in 

the Contents List view. 

➢ The masks element specifies the mask(s) used for synchronization detection. 

➢ The plots element defines the charts applicable to the data.  

➢ The transformation element specifies the data transformation applicable to the data. 

A field is defined by a name attribute, with the path of the field as value. The path of the field is defined 

by the concatenation of the several item names in the hierarchical structure defining the binary data. 

Only a field, defined under the packet_list_columns, can have an attribute indicator (with value colour). 

The presence of this indicator is used to select the value during colour coding of the packets. 
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Figure 28: Example of Mission Definition file  

 

4.2.2. Mission Data Definition Schemas 

The Mission Data Definition schemas are XSD schemas adapted (according to [RD.1]) to describe the 

structure of the binary items inside the data files. Although each schema file could have been defined 

independently, considering that they can share schema types, the structure shown in Figure 27 has been 

used for the default missions provided with S2G. Section 5.13 provides some guidelines on how the user 

can customize an existing mission configuration. 
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4.2.3. CFDP Extension 

Additional Mission Data schema files are needed to define the binary contents of the CFDP dedicated 

levels (CFDP Space Packets and CFDP PDUs): 

 

Figure 29: Mission Configuration files structure (CFDP Extension) 
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5. OPERATIONS  

5.1. Installation Procedure 

See section 3 (Getting Started). 

 

5.2. Launch S2G 

See section 3 (Getting Started). 

 

5.3. Exit S2G 

To close S2G proceed as follow: 

1. Select menu “File” → “Exit”. 

 

5.4. Select Active Mission 

The file types available when opening a data file is related to the currently active mission. To change the 

active mission, proceed as follow: 

1. Open the preferences pages (“Edit” → “Preferences”). 

2. Inside the “S2G Data Viewer”, select the “Mission Configuration” page. 

3. Select the new active mission using the combo box “Selected Mission” shown in Figure 30. 

4. Press OK to finish configuration setup. 
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Figure 30: Active Mission Configuration 

5.5. Mission Configuration Management 

S2G enables the use of customized missions, loading their data at startup. This functionality is available 

by activating the menu item “Edit” → “Mission Configuration” (shown in Figure 31). The user is able 

to: export an existing mission (to have access to the defining files); import a new mission; and discard 

an existing mission. From the point of view of S2G there are two categories of mission definitions: the 

standard missions and the custom missions. 

 

Figure 31: Mission Configuration 

5.5.1. Export Mission 

To export existing mission files proceed as follow: 
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1. Launch the Mission Configuration dialog through menu “Edit” → “Mission Configuration” 

(Figure 31) 

2. Select the mission category to manage (custom or standard) in the left hand side of the dialog; 

3. Select the mission file to be exported in the missions list; 

4. Press button “Export Mission” and select the directory where to save the file, finishing with OK. 

After this step, the mission jar file shall be available in the chosen location. 

5.5.2. Discard Mission 

To discard existing mission files proceed as follow: 

1. Launch the Mission Configuration dialog through menu “Edit” → “Mission Configuration” 

(Figure 31) 

2. Select the mission category to manage (custom or standard) in the left hand side of the dialog; 

3. Select the mission file to be discarded in the missions list; 

4. Press button “Discard Mission” confirming with OK the deletion message that is shown. After 

this step, the mission is no longer available in the application. 

5.5.3. Import Mission 

To import a new mission file proceed as follow: 

1. Launch the Mission Configuration dialog through menu “Edit” → “Mission Configuration” 

(Figure 31) 

2. Select the mission category to manage (custom or standard) in the left hand side of the dialog; 

3. Press button “Import Mission”; 

4. Select the file to import from the file open dialog and finish with OK. After this step the new 

mission shall be available in the application. 

 

5.6. Open File 

To open a data file proceed as follow: 

1. Launch the Open file dialog through menu “File” → “Open” (Figure 32) 

Note: this step can also be performed thought the “Open File” button in the toolbar; or using the 

keyboard shortcut (Ctrl-O). 

2. Select the type of file to be open, in the file type combo box. 

3. Select the file to open, and finish with OK. After this step, a progress dialog is shown while 

loading the file (Figure 33), and the file will appear listed in the Product Files view (Figure 34). 
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Figure 32: Open file dialog (with types of files) 

 

 

Figure 33: Progress bar when loading file 

 

 

Figure 34: S2G Main Window displaying file contents 
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While opening a file, S2G may try (if data unit offset synchronisation is enabled in the Preferences) to 

match the bit patterns (if any) defined by the mission definition file (see section 4.2.1 for details) in 

order to check for data units synchronization. When synchronization errors are detected S2G will issue a 

warning to the user, as seen in Figure 35. The user can then generate the full quality report to access 

detailed information about synchronization errors. Note that the current offset synchronisation status 

(on/off) is indicated in the status bar at the bottom of the main screen. 

 

 

Figure 35: Warning dialog when Synchronization Errors are detected 

 

5.7. Data Unit Inspection 

To inspect the content of a file in the Product Files list view, consider the following operations. 

5.7.1. Inspect a Data Unit 

To inspect the contents of a file, proceed as follow: 

1. In the Data Unit list view, scroll to the packet to inspect. 

2. Select by clicking over the row of the desired data unit 

Note: This selection can also be performed with the cursor keys; and the packet selection is 

highlighted in a shade of pink. 

After step 2), the selected item is represented in the Data Unit Details view in a hierarchical structure, 

and the Hexadecimal view is automatically scrolled to show the beginning of the packet in the file.  

5.7.2. Inspect Data Unit fields 

To inspect the field of a content item, proceed as follow: 

1. In the Data Unit Details view, expand the nodes of the item structure to display the field to 

inspect. 

Note: The content item structure is shown only if a file and data unit is selected. 

2. Select by clicking over the desired item field. Passing the mouse over the field value displays 

alternate representations of the field value in a tooltip. 

Note: the data unit field selection is highlighted in a shade of pink. 

After step 2), the byte storing the selected item field is highlighted with a pink shade in the hexadecimal 

view. 
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5.7.3. Clear Data Unit field selection 

To clear the selection of Data Unit field, proceed as follow: 

1. In the Data Unit List view, scroll the currently selected item into view 

2. Double click on the currently selected data unit. 

 

5.8. Search 

5.8.1. Hexadecimal Value 

S2G enables the search by hexadecimal and text file content. To search for a raw file content proceed as 

follows: 

1. Display the find bar (by activating the menu item “Window” → “Toggle Find Bar” or through the 

keyboard shortcut Ctrl + “F”) – the find bar is shown on top of the Hexadecimal view as in 

Figure 36. 

2. Select the search mode from the combo box listing: Hexadecimal to search for hexadecimal 

values (contents on the left side of the view); Text to search for text (contents on the right side of 

the view). 

3. Enter the value to search in the text box labeled “Find:” 

Note 1: Hexadecimal values cannot contain spaces (e.g. search for AE3B to find the two next bytes 

“AE 3B” in the file. 

Note 2: Non-printable characters are represented by the dot (‘.’) character. As such, the dot 

character cannot be used for matching during search. 

4. Press enter to activate the forward search. Forward and backward search can also be activated 

using down and up arrow, respectively. 

 

 

Figure 36: Find Bar for Hexadecimal Search 

 

5.9. Quality Report 

To generate a quality report proceed as follows: 

1. Select the file in the Product View. 

2. Select menu “Tools” → “Show Report” (or click the “Show Report” button in the toolbar). After 

this step, while the report is being generated the user can evaluate the progress in a progress 

dialog. 
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3. When the report is finished, a dialog is shown (Figure 37) to the user that enables opening the 

report in an external browser from a default location, or save it in a user specified location. 

 

  

Figure 37: Finished Quality report dialog 

 

In order to avoid a consumption of a large amount of memory, S2G limits the number of events in the 

report (this number can be configured in the Application Settings preferences). The information about 

the size of the report is provided in the dialog, in order to help the user evaluate if displaying the report 

in a web browser is feasible. 

The report is stored in XML format, which when rendered by a Web Browser with the style sheet 

provided by S2G is displayed as shown in Figure 38. 

 

 

Figure 38: Quality report displayed in external Web Browser 
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5.9.1. Description of the Quality Report contents 

The Quality Report is divided in 3 sections: 

➢ File Properties, containing information about the file selected for quality check; 

➢ Summary, presenting a list of items summarizing the result of the quality check; 

➢ Events, containing a list of detailed information items for each event detected during the quality 

check. 

The content of each section is detailed in the next sections of this document. Please note that the checks 

performed by the quality report are done over uncorrected data. Also, Reed-Solomon and CRC fields are 

not checked on-the-fly (errors reported in the quality report, are not highlighted in the data unit fields 

view). These checks are only performed in the scope of the quality report. 

5.9.1.1. File Properties 

This section is equal for all file types and contains the items in Table 5. 

 

 

 

Table 5: File Properties in the Quality Report 

File Properties 
Scrambled 

CADU 
Unscrambled 

CADU 
TF ISP 

File Name x x x x 

File Path x x x x 

File Size x x x x 

Report Date x x x x 

Report Generation Time x x x x 

 

5.9.1.2. Summary  

The items listed in the Summary section of the quality report depend on the type of the input product. 

Table 6 presents a description of the listed items for each type. 

 

Table 6: Summary information in the Quality Report 

Item 
Scrambled 

CADU 
Unscrambled 

CADU 
TF ISP 

Total Nr of Synchronization Errors x x x x 

Number of CADUs x x   
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Number of RS errors in the header  x x  

Total Number of TFs   x  

Number of Idle TFs   x  

Number of Frame Counter Discontinuities   x  

Total Number of ISPs    x 

Number of Idle ISPs    x 

First Timestamp    x 

Last Timestamp    x 

Number of SSC gaps    x 

Number of Duplicated ISPs    x 

Number of ISPs Timestamp Discontinuities    x 

Number of CRC errors    x 

 

5.9.1.3. Events 

This section contains the detailed information of detected events. If no event is detected, the section is 

empty. The events that can be detected and displayed depend on the type of the input product. 

Each event is presented in the form of a table, containing always (among other relevant fields specific of 

the event): 

➢ Report entry number; 

➢ The event message; 

➢ Data unit number (i.e., number of the CADU, TF or ISP within the file); 

➢ Data unit offset (i.e., the offset in bytes from the CADU, TF or ISP file origin); 

 

Table 7 shows the description of the main events detected by S2G according to the product type. 

 

Table 7: Events in the Quality Report 

Event Message Description 
Scrambled 

CADU 
Unscrambled 

CADU 
TF ISP 

Stream 

Synchronization 

The synchronization was lost at some point. 

The lost offset where the sync was lost is 

detailed in the event, as well as the re-sync 

offset. 

x x x x 
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Event Message Description 
Scrambled 

CADU 
Unscrambled 

CADU 
TF ISP 

Reed Solomon 

uncorrectable 

errors detected 

(during quality 

check) 

Reed-Solomon errors that cannot be corrected 

were detected in the data unit (due to the 

large amount of the incorrect bits, the RS 

algorithm is unable to recover all errors). 
 x   

Reed Solomon 

errors detected 

(during quality 

check) 

Correctable Reed-Solomon errors were 

detected in the data unit. 

The interleaving level, symbol offset, 

expected value and found value are provided 

for each correctable error detected in the data 

unit. 

 x   

CRC error 

detected 

The calculation of the CRC over the data unit 

fields does not match the CRC value 

provided. 

SSC, APID and Time Code Field values are 

provided in the event details. 

  x x 

Frame Counter 

discontinuity 

A jump from the previous transfer frame 

number and the current one was detected, 

indicating a discontinuity. 

Information about the previous TF and the 

current one is provided in the event details. 

  x  

Unknown APID 

detection 

An invalid APID value was detected. 
   x 

Invalid SSC Gap 

detected 

A jump in the SSC between the previous ISP 

and the current one was detected. 

Information about the previous ISP and the 

current one is provided in the event details. 

   x 

Timestamp 

discontinuity 

A jump between the previous Time Code 

Field and the current one was detected, 

indicating a discontinuity. The timestamp is 

expected to be continuously increasing. 

Information about the previous ISP and the 

current one is provided in the event details. 

   x 

Duplicated ISP An ISP with the same SSC, APID and Time 

Code Field values as a previously analyzed 

ISP is detected. 

Information about the original ISP and the 

current one is provided in the event details. 

   x 

 

5.9.2. Batch Quality Report Generation 

The user can also generate quality reports in batch mode for a: (a) set of selected files or (b) all files in a 

set of selected folders. When choosing to generate the report for a set of folder the user may choose to 
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iterate recursively into existing sub-folders. In either mode the user is prompted to select of given file 

type and the report generation proceeds assuming all selected files correspond to that data type. The 

quality report file is stored in the same location of the source data file, with the same name and 

extension ‘xml’. 

5.10. Data Plotting  

To generate a plot of the data proceed as follows: 

1. Select the file in the Product View. 

2. Select menu “Tools” → “Show Plot” (or click the “Show Plot” button in the toolbar). After this 

step, while the plot is being generated the user can evaluate the progress in a progress dialog. 

3. When finished, the plot is shown in dialog (Figure 39). The user can display the several plot types, 

by selecting them in the top combo box. The user can also select between the available chart 

types: XY Chart and Pie Chart. 

4. The user can store the plot data (stored in XML format similar to the quality report), or save the 

plot image using the button at the bottom of the dialog. 

Note: the user can zoom in/out using the popup menu activated by a left click in the plot area.  

 

 

Figure 39: Data plotting dialog – XY Chart 
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Figure 40: Data plotting dialog – Pie Chart 

5.11. Data Transformation 

To perform a data transformation operation proceed as follows: 

1. Select the file in the Product View. 

2. Select menu “Tools” → “Transform” (or click the “Transform” button in the toolbar), to show the 

transformation dialog (Figure 41). Depending on the type of file selected as source of 

transformation the dialog will request different transformation parameters. 

a. Scrambled CADU to Descrambled CADU 

i.  “Polynomial” is the descrambling polynomial to be used 

ii.  “Apply RS correction” activates RS correction; otherwise data is not checked 

after descrambling 

iii. “Generate report” to generate a report containing all inconsistencies of the source 

file plus all issues detected during the actual transformation 

b. CADU to TF 

i. “Cutoff file” activates a cutoff of the size of the file; this cutoff is based on the 

values of “Cutoff size (Mb)” and “Cutoff # data units”. Cutoff value of 0 means 

that no cutoff is to be applied. S2G with consider both cutoffs at the same time. 

ii.  “Discard idle frames” allows filtering idle frames 
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iii.  “Split output files by SCID” allows to generate separate files containing data units 

related to a single Spacecraft  ID 

iv.  “Split output files by VCID” allows to generate separate files containing data 

units related to a single Virtual Channel ID 

v. “Generate report” to generate a report containing all inconsistencies of the source 

file plus all issues detected during the actual transformation 

c. TF to ISP 

i.  “Cutoff file” activates a cutoff of the size of the file; This cutoff is based on the 

values of “Cutoff size (Mb)” and “Cutoff # data units”. Cutoff value of 0 means 

that no cutoff is to be applied. S2G with consider both cutoffs at the same time. 

ii.  “Split output files by APID” allows to generate separate files containing data units 

related to a single APID 

iii.  “Discard idle packets” allows filtering idle ISPs 

iv.  “Generate report” to generate a report containing all inconsistencies of the source 

file plus all issues detected during the actual transformation 

d. Annotated CADU to CADU (available if Annotated CADU type defined) 

e. Annotated ISP to ISP (available if Annotated ISP type defined) 

3. Once the transformation is properly configured (including the target file), click the “Transform” 

button, and confirm the parameters in the confirmation dialog. After this step, while the 

transformation is being performed the user can evaluate the progress in a progress dialog. 

4. When the transformation is finished, if the report generation was activated, a dialog is shown to 

the user that enables opening the report in an external browser from a default location, or save it 

in a user specified location. 
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Figure 41: Transformation Dialogs 

5.11.1. CFDP Extension 

The following additional transformation operations are available for CFDP data units: 

➢  CFDP Space Packet to PDU 

i. “Cutoff file” activates a cutoff of the size of the file; this cutoff is based on the values of 

“Cutoff size (Mb)” and “Cutoff # data units”. Cutoff value of 0 means that no cutoff is to 

be applied. S2G with consider both cutoffs at the same time. 

ii. “Generate report” to generate a report containing all inconsistencies of the source file plus 

all issues detected during the actual transformation 

 

Figure 42: CFDP Space Packet to PDU transformation dialog 
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5.12. Close File 

To close a data file proceed as follows: 

1. Select the file in the Product View. 

2. Select menu “File” → “Close”. After this step, the file will disappear from the list in the Product 

Files view. 

Note: this step can also be performed thought the “Close File” button in the toolbar. 

 

5.13. Customize Mission Data Specification 

The information is provided in section 3.3 of [RD.3]. 

 

5.14. Add a script to S2G 

The scripts accessible through menu “Scripts” → “Execute Script” are located in a specific directory in 

S2G workspace $WORKSPACE/resources/scripts. To ease the access to the specific directory a 

symbolic link is available directly in S2G installation directory. In order to add a script to S2G the user 

needs to copy the script into the scripts directory. To be identified as a script the file needs to be set with 

execution privileges. Once copied the script shall be immediately available in S2G the next time menu 

“Scripts” → “Execute Script” is activated with no need to restart the application. 

5.14.1. Add SNEAK ISP Extractor to S2G 

SNEAK ISP Extractor extracts specific ISP field(s) into a CSV text file. 

SNEAK can be downloaded from https://eop-cfi.esa.int/index.php/applications/sneak and the following 

content should be placed in S2G scripts folder ($WORKSPACE/resources/scripts): “fields.txt”, 

“isp_extractor” script file, folders “lib”, “share” and “bin” (where “isp_field_extractor” binary file is the 

only one needed from “bin”). ISP Extractor will make use of mission and ISP file selected in S2G. 

When running “isp_extractor” script from S2G, a folder “schema” will be created in S2G scripts folder 

with the needed schema files extracted from S2G mission jar file ($WORKSPACE/resources/data). The 

output will be saved as “<isp file name>_fields.csv” to S2G scripts folder. 

5.15. Mask Editor 

S2G has available a mechanism to dynamically synchronize the data units offsets when parsing data. 

This option can be enable thru the preferences dialog as indicated in section 4.1.7. The masks used in 

the synchronization are supplied in the mission specification schemas as described in section 5.13. To 

aid the user in defined the adequate value of the hexadecimal mask S2G provides a mask editor through 

menu “Tools” → “Mask Editor” (see Figure 43). 
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Figure 43: Mask Editor – TF V1 screen 

The Mask Editor is composed of the following elements: 

➢ A Schema Type selection (CADU, TF, ISP). For TF selection the user can also select among V1 

and V2 format; 

➢ A ‘Reference Value’ hexadecimal field, which the user can edit to represent a typical value of the 

data to be synchronized; 

➢ A ‘Bit Mask’ hexadecimal field, which corresponds to the mask to apply to the data; 

➢ A ‘Masked Value’ field, showing the application of the mask to the reference value; 

➢ A figure summarizing the structure of the selected schema type header; 

➢ A set of bit buttons, which the user can toggle to edit the bit mask on a bit by bit level. 
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6. COMMAND LINE 

6.1. How to run from command line: 

S2G can be called with command line arguments to easy the opening of the S2G window GUI with a 

product file loaded. 

Those commands line arguments will set the mission schema, the schema type and the product file to be 

loaded. 

To call S2G with arguments use: 

 s2g -cli -schema_type “type” -mission_file “path/to/file” -product_file “path/to/file/”  

Where: 

1. “-cli” flag indicates whether to use command line arguments or not 

2. “-schema-type” can have one of five values: Scrambled_CADU, CADU, TF, ISP, Annotated_ISP 

3. “-mission_file” is the path to the mission schemas 

4. “-product_file” is the path to the product file 

6.2. Where is the "s2g" command in the different target 
environments: 

The "s2g" command is handled differently, depending of the target environment. Check where to find 

the "s2g" command for your case: 

• macOS: ./s2g.app/Contents/MacOS/s2g 

• Linux: ./s2g 

• Windows: ./s2g.exe 

Due to behavior of Windows Command Line, when executing an ‘.exe’ the command line will not wait 

to finish its execution. Due to this behavior, messages sent to standard output (like validation of 

command line arguments), will not be shown. It is recommended to add “| more” at the end of the 

command. Example command: “s2g.exe -cli -schema_type "type" -mission_file "path/to/file" - 

product_file "path/to/file | more" 



 

S2G Data Viewer 

User Manual 

Code  : S2G-DME-TEC-SUM023 

Issue : 1.L 

Date : 27/03/2025 

Page : 57 of 59 

 

 

© DEIMOS Engenharia S.A.. 

RESTRICTED 

DME-DQS-SUPTR05-TNO-20-E 

7. TROUBLESHOOTING 

7.1. Problem: Unable to find CADU sync marker 

The first step performed when opening a CADU file is to find the sync marker to calculate the offset of 

the beginning of the first CADU stored in the file. The error dialog in Figure 44 is displayed if the tool 

is unable to find the sync marker. 

To correct this issue, consider: 

➢ verifying that the selected file does in fact contain CADU packets 

➢ verifying that the value for the sync marker is correctly specified in the mission data schemas (refer 

to section 5.13 for details on how to customize mission data schemas) 

 

Figure 44: Error dialog (Unable to find CADU Sync Marker). 

 

7.2. Problem: Unable to load mission definition schema 

When a data file is open, the tool interprets the file contents according to the mission data schema. If a 

syntax problem is found while loading the schema, an error dialog is shown indicating the problem’s 

cause – see example in Figure 45. 

This issue can be corrected by editing the XSD schema file indicated in the error dialog. 

 

 

Figure 45: Error dialog (Unable to load mission definition schema). 
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7.3. Problem: Corrupted workspace 

The contents of the workspace created automatically when S2G is launched for the first time are not 

expected to be edited by the user. However, if the workspace content becomes corrupted by some 

external reason, the user can revert to the default by proceeding as follows: 

1. Delete the workspace directory. 

2. Restart the application. 

Note: Upon restart, S2G rebuilds the workspace contents with default values. 

7.4. Problem: Synchronization related issues 

While opening a file, S2G may try (if data unit offset synchronisation is enabled in the Preferences) to 

match the bit patterns (if any) defined by the mission definition file (see section 4.2.1 for details) in 

order to check for data units synchronization. To optimize the loading operation the synchronization 

result is stored in a cache for future use when re-loading the same file. 

In case the cached data becomes inadequate for the originally loaded data the application may show 

some misbehaviour: the quality report signals errors while looking at the data there is no underlying 

problem or even several executions of the quality report result in different set of errors. 

This issue can be corrected by clearing the synchronization offset cache (refer to section 4.1.7, Figure 

23)  
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